Description
A flaw has been found in vllm-project vLLM up to 0.26.0. This vulnerability affects unknown code of the file rust/src/parser/src/unified/gemma4.rs of the component Gemma4UnifiedParser. Executing a manipulation can lead to denial of service. The attack may be launched remotely. The exploit has been published and may be used. Upgrading to version 0.29.1rc0 is able to resolve this issue. This patch is called 3439bad37e68ba9755a46f4f6b44a4aeaf1f60a9. Upgrading the affected component is advised.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
vllm-project vLLM
0.1affected0.2affected0.3affected0.4affected0.5affected0.6affected0.7affected0.8affected0.9affected0.10affected0.11affected0.12affected0.13affected0.14affected0.15affected0.16affected0.17affected0.18affected0.19affected0.20affected0.21affected0.22affected0.23affected0.24affected0.25affected0.26.0affected0.29.1rc0unaffected
References
- https://vuldb.com/vuln/411965 ↗
- https://vuldb.com/vuln/411965/cti ↗
- https://vuldb.com/cve/CVE-2026-103241 ↗
- https://vuldb.com/submit/956250 ↗
- https://github.com/vllm-project/vllm/issues/50927 ↗
- https://github.com/vllm-project/vllm/pull/54303 ↗
- https://gist.github.com/Yunzez/8e98d656aa667095b513161eb056d28e ↗
- https://github.com/vllm-project/vllm/commit/3439bad37e68ba9755a46f4f6b44a4aeaf1f60a9 ↗
- https://github.com/vllm-project/vllm/releases/tag/v0.29.1rc0 ↗
- https://github.com/vllm-project/vllm/ ↗