Skip to content
CVE PROGRAM SOURCE RECORD9.1 Critical

CVE-2026-101296

Apache Tomcat: JNDIRealm bind credential validation fails open for non-GSSAPI SASL mechanisms

Description

A missing critical step in authentication vulnerability in Apache Tomcat when the JNDI realm was configured with with a non GSSAPI SASL authentication mechanism allowed attackers to authenticate without providing the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.26, from 10.1.0-M1 through 10.1.60, from 9.0.0.M1 through 9.0.122. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Tomcat

Default version status: unaffected

  • 11.0.0-M1 to ≤ 11.0.26affected
  • 10.1.0-M1 to ≤ 10.1.60affected
  • 9.0.0.M1 to ≤ 9.0.122affected
  • 8.5.0 to ≤ 8.5.100affected
  • 7.0.0 to ≤ 7.0.109affected

References