Skip to content
CVE PROGRAM SOURCE RECORD9.3 Critical

CVE-2025-9803

Improper Authentication in lunary-ai/lunary

Description

lunary-ai/lunary version 1.9.34 is vulnerable to an account takeover due to improper authentication in the Google OAuth integration. The application fails to verify the 'aud' (audience) field in the access token issued by Google, which is crucial for ensuring the token is intended for the application. This oversight allows attackers to use tokens issued to malicious applications to gain unauthorized access to user accounts. The issue is resolved in version 1.9.35.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

lunary-ai lunary-ai/lunary

  • unspecified to < 1.9.35affected

References