Skip to content
CVE PROGRAM SOURCE RECORD7.0 High

CVE-2025-8447

Incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed read-only access

Description

An improper access control vulnerability was identified in GitHub Enterprise Server that allowed users with access to any repository to retrieve limited code content from another repository by creating a diff between the repositories. To exploit this vulnerability, an attacker needed to know the name of a private repository along with its branches, tags, or commit SHAs that they could use to trigger compare/diff functionality and retrieve limited code without proper authorization. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18, and was fixed in versions 3.14.17, 3.15.12, 3.16.8 and 3.17.5. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

GitHub Enterprise Server

Default version status: affected

  • 3.14 to ≤ 3.14.16affected
  • 3.15 to ≤ 3.15.11affected
  • 3.16 to ≤ 3.16.7affected
  • 3.17 to ≤ 3.17.4affected

References