Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2025-7338

Multer vulnerable to Denial of Service via unhandled exception from malformed request

Description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.2 to receive a patch. No known workarounds are available.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

expressjs multer

Default version status: unaffected

  • 1.4.4-lts.1 to < 2.0.2affected

References