Skip to content
CVE PROGRAM SOURCE RECORD5.1 Medium

CVE-2025-71404

better-auth before 1.1.16 Reflected XSS via error parameter

Description

better-auth versions after v0.0.2 and before 1.1.16 contain a reflected cross-site scripting (XSS) vulnerability on the /api/auth/error page, where the value of the 'error' URL parameter is reflected as HTML without proper neutralization. An attacker who coerces a user into visiting a specially-crafted URL can execute arbitrary JavaScript in the context of the user's browser. The issue is fixed in version 1.1.16.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

better-auth better-auth

Default version status: unaffected

  • 0 to < 1.1.16affected
  • 1.1.16unaffected
pkg:npm/better-auth

References