Skip to content
CVE PROGRAM SOURCE RECORD5.3 Medium

CVE-2025-6981

Incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed unauthorized read-only access

Description

An incorrect authorization vulnerability allowed unauthorized read access to the contents of internal repositories for contractor accounts when the Contractors API feature was enabled. The Contractors API is a rarely-enabled feature in private preview. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18 and was fixed in versions 3.14.15, 3.15.10, 3.16.6 and 3.17.3

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

GitHub Enterprise Server

Default version status: affected

  • 3.14.0 to < 3.14.15affected
  • 3.15.0 to < 3.15.10affected
  • 3.16.0 to < 3.16.6affected
  • 3.17.0 to < 3.17.3affected

References