Skip to content
CVE PROGRAM SOURCE RECORD5.1 Medium

CVE-2025-69289

Discourse has insecure default configuration that allows non-admin moderators to takeover any non-staff account via email change

Description

Discourse is an open source discussion platform. A privilege escalation vulnerability in versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 allows a non-admin moderator to bypass email-change restrictions, allowing a takeover of non-staff accounts. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, ensure moderators are trusted or enable the "require_change_email_confirmation" setting.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

discourse discourse

  • < 3.5.4affected
  • >= 2025.11.0-latest, < 2025.11.2affected
  • >= 2025.12.0-latest, < 2025.12.1affected
  • >= 2026.1.0-latest, < 2026.1.0affected

References