Skip to content
CVE PROGRAM SOURCE RECORD7.6 High

CVE-2025-69262

pnpm vulnerable to Command Injection via environment variable substitution

Description

pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

pnpm pnpm

  • >=6.25.0, < 10.27.0affected

References