Skip to content
CVE PROGRAM SOURCE RECORD9.1 Critical

CVE-2025-69222

LibreChat is vulnerable to Server-Side Request Forgery due to missing restrictions

Description

LibreChat is a ChatGPT clone with additional features. Version 0.8.1-rc2 is prone to a server-side request forgery (SSRF) vulnerability due to missing restrictions of the Actions feature in the default configuration. LibreChat enables users to configure agents with predefined instructions and actions that can interact with remote services via OpenAPI specifications, supporting various HTTP methods, parameters, and authentication methods including custom headers. By default, there are no restrictions on accessible services, which means agents can also access internal components like the RAG API included in the default Docker Compose setup. This issue is fixed in version 0.8.1-rc2.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

danny-avila LibreChat

  • >= 0.8.1-rc2, 0.8.2-rc2affected

References