Skip to content
CVE PROGRAM SOURCE RECORD8.7 High

CVE-2025-68698

Jervis has an RSA PKCS#1 v1.5 Padding Vulnerability

Description

Jervis is a library for Job DSL plugin scripts and shared Jenkins pipeline libraries. Prior to 2.2, Jervis uses PKCS1Encoding which is vulnerable to Bleichenbacher padding oracle attacks. Modern systems should use OAEP (Optimal Asymmetric Encryption Padding). This vulnerability is fixed in 2.2.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

samrocketman jervis

  • < 2.2affected

References