Skip to content
CVE PROGRAM SOURCE RECORD4.3 Medium

CVE-2025-68659

Discourse has DoS vulnerability in username change endpoint

Description

Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have an application level denial of service vulnerabilityin the username change functionality at try.discourse.org. The vulnerability allows attackers to cause noticeable server delays and resource exhaustion by sending large JSON payloads to the username preference endpoint PUT /u//preferences/username, resulting in degraded performance for other users and endpoints. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. No known workarounds are available.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

discourse discourse

  • < 3.5.4affected
  • >= 2025.11.0-latest, < 2025.11.2affected
  • >= 2025.12.0-latest, < 2025.12.1affected
  • >= 2026.1.0-latest, < 2026.1.0affected

References