Skip to content
CVE PROGRAM SOURCE RECORD8.1 High

CVE-2025-68493

Apache Struts, Apache Struts: XXE vulnerability in outdated XWork component

Description

Missing XML Validation vulnerability in Apache Struts, Apache Struts. This issue affects Apache Struts: from 2.0.0 before 2.2.1; Apache Struts: from 2.2.1 through 6.1.0. Users are recommended to upgrade to version 6.1.1, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Struts

Default version status: unaffected

  • 2.0.0 to < 2.2.1affected

Apache Software Foundation Apache Struts

Default version status: unaffected

  • 2.2.1 to ≤ 6.1.0affected

References