Skip to content
CVE PROGRAM SOURCE RECORD7.2 High

CVE-2025-66631

CSLA .NET is vulnerable to Remote Code Execution via WcfProxy

Description

CSLA .NET is a framework designed for the development of reusable, object-oriented business layers for applications. Versions 5.5.4 and below allow the use of WcfProxy. WcfProxy uses the now-obsolete NetDataContractSerializer (NDCS) and is vulnerable to remote code execution during deserialization. This vulnerability is fixed in version 6.0.0. To workaround this issue, remove the WcfProxy in data portal configurations.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

MarimerLLC csla

  • < 6.0.0affected

References