Skip to content
CVE PROGRAM SOURCE RECORD8.4 High

CVE-2025-66627

Wasmi's Linear Memory has a Critical Use After Free Vulnerability

Description

Wasmi is a WebAssembly interpreter focused on constrained and embedded systems. In versions 0.41.0, 0.41.1, 0.42.0 through 0.47.1, 0.50.0 through 0.51.2 and 1.0.0, Wasmi's linear memory implementation leads to a Use After Free vulnerability, triggered by a WebAssembly module under certain memory growth conditions. This issue potentially leads to memory corruption, information disclosure, or code execution. This issue is fixed in versions 0.41.2, 0.47.1, 0.51.3 and 1.0.1. To workaround this issue, consider limiting the maximum linear memory sizes where feasible.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

wasmi-labs wasmi

  • >= 0.41.0, < 0.41.2affected
  • >= 0.42.0, < 0.47.1affected
  • >= 0.50.0, < 0.51.3affected
  • >= 1.0.0, < 1.0.1affected

References