Skip to content
CVE PROGRAM SOURCE RECORD5.3 Medium

CVE-2025-66451

LibreChat's Improper Input Validation in Prompt Creation API Enables Unauthorized Permission Changes

Description

LibreChat is a ChatGPT clone with additional features. In versions 0.8.0 and below, when creating prompts, JSON requests are sent to define and modify the prompts via PATCH endpoint for prompt groups (/api/prompts/groups/:groupId). However, the request bodies are not sufficiently validated for proper input, enabling users to modify prompts in a way that was not intended as part of the front end system. The patchPromptGroup function passes req.body directly to updatePromptGroup() without filtering sensitive fields. This issue is fixed in version 0.8.1.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

danny-avila LibreChat

  • < 0.8.1affected

References