Skip to content
CVE PROGRAM SOURCE RECORD6.5 Medium

CVE-2025-66170

Apache CloudStack: Any user can list backups that they should not have access to

Description

The CloudStack Backup plugin has an improper authorization logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and has access to specific APIs can list backups from any account in the environment. This vulnerability does not allow them to see the contents of the backup. Users are recommended to upgrade to version 4.22.0.1, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache CloudStack

Default version status: unaffected

  • 4.21.0.0 to ≤ 4.22.0.0affected

References