Skip to content
CVE PROGRAM SOURCE RECORD5.3 Medium

CVE-2025-66169

Apache Camel Neo4j: Cypher injection vulnerability in Camel-Neo4j component

Description

Cypher Injection vulnerability in Apache Camel camel-neo4j component. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.3, from 4.15.0 before 4.17.0 Users are recommended to upgrade to version 4.10.8 for 4.10.x LTS and 4.14.3 for 4.14.x LTS and 4.17.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Camel Neo4j

Default version status: unaffected

  • 4.10.0 to < 4.10.8affected
  • 4.14.0 to < 4.14.3affected
  • 4.15.0 to < 4.17.0affected

References