Skip to content
CVE PROGRAM SOURCE RECORD6.6 Medium

CVE-2025-65960

Contao is vulnerable to remote code execution in template closures

Description

Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, back end users with precise control over the contents of template closures can execute arbitrary PHP functions that do not have required parameters. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves manually patching the Contao\Template::once() method.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

contao contao

  • >= 4.0.0, < 4.13.57affected
  • >= 5.0.0-RC1, < 5.3.42affected
  • >= 5.4.0-RC1, < 5.6.5affected

References