Skip to content
CVE PROGRAM SOURCE RECORD7.3 High

CVE-2025-65199

Windscribe for Linux 'changeMTU' local privilege escalation

Description

A command injection vulnerability exists in Windscribe for Linux Desktop App that allows a local user who is a member of the windscribe group to execute arbitrary commands as root via the 'adapterName' parameter of the 'changeMTU' function. Fixed in Windscribe v2.18.3-alpha and v2.18.8.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Windscribe Windscribe for Linux Desktop App

Default version status: unknown

  • 2.10.1 to < 2.18.3-alphaaffected
  • 2.10.1 to < 2.18.8affected
  • 2.18.3-alphaunaffected
  • 2.18.8unaffected

References