Skip to content
CVE PROGRAM SOURCE RECORD4.8 Medium

CVE-2025-62265

Cross-site scripting (XSS) vulnerability in the Blogs widget in Liferay Portal 7.4.0 through 7.4.3.111, and older unsupported versions, and Liferay DXP 2023.Q4.0 through 2023.Q4.10

Description

Cross-site scripting (XSS) vulnerability in the Blogs widget in Liferay Portal 7.4.0 through 7.4.3.111, and older unsupported versions, and Liferay DXP 2023.Q4.0 through 2023.Q4.10, 2023.Q3.1 through 2023.Q3.8, 7.4 GA through update 92, 7.3 GA through update 36, and older unsupported versions allows remote attackers to inject arbitrary web script or HTML via a crafted <iframe> injected into a blog entry's “Content” text field The Blogs widget in Liferay DXP does not add the sandbox attribute to <iframe> elements, which allows remote attackers to access the parent page via scripts and links in the frame page.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Liferay Portal

Default version status: unaffected

  • 7.4.0 to ≤ 7.4.3.111affected

Liferay DXP

Default version status: unaffected

  • 7.4.13 to ≤ 7.4.13-u92affected
  • 2023.Q3.1 to ≤ 2023.Q3.8affected
  • 2023.Q4.0 to ≤ 2023.Q4.10affected

References