Skip to content
CVE PROGRAM SOURCE RECORD8.1 High

CVE-2025-62235

Apache Mynewt NimBLE: Incorrect handling of SMP Security Request could lead to undesirable pairing

Description

Authentication Bypass by Spoofing vulnerability in Apache NimBLE. Receiving specially crafted Security Request could lead to removal of original bond and re-bond with impostor. This issue affects Apache NimBLE: through 1.8.0. Users are recommended to upgrade to version 1.9.0, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Mynewt NimBLE

Default version status: unaffected

  • 0 to ≤ 1.8.0affected

References