Skip to content
CVE PROGRAM SOURCE RECORD2.1 Low

CVE-2025-61594

URI Credential Leakage Bypass over CVE-2025-27221

Description

URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

ruby uri

  • < 0.12.5affected
  • >= 0.13.0, < 0.13.3affected
  • >= 1.0.0, < 1.0.4affected

References