Skip to content
CVE PROGRAM SOURCE RECORD9.3 Critical

CVE-2025-59954

Knowage Contains a Remote Code Execution Vulnerability

Description

Knowage is an open source analytics and business intelligence suite. Versions 8.1.26 and below are vulnerable to Remote Code Exection through using an unsafe org.apache.commons.jxpath.JXPathContext in MetaService.java service. This issue is fixed in version 8.1.27.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

KnowageLabs Knowage-Server

  • < 8.1.27affected

References