Skip to content
CVE PROGRAM SOURCE RECORD4.3 Medium

CVE-2025-59454

Apache CloudStack: Lack of user permission validation leading to data leak for few APIs

Description

In Apache CloudStack, a gap in access control checks affected the APIs - createNetworkACL - listNetworkACLs - listResourceDetails - listVirtualMachinesUsageHistory - listVolumesUsageHistory While these APIs were accessible only to authorized users, insufficient permission validation meant that users could occasionally access information beyond their intended scope. Users are recommended to upgrade to Apache CloudStack 4.20.2.0 or 4.22.0.0, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache CloudStack

Default version status: unaffected

  • 4.0.0 to < 4.20.2affected
  • 4.21.0 to < 4.22.0affected

References