Skip to content
CVE PROGRAM SOURCE RECORD9.8 Critical

CVE-2025-59059

Apache Ranger: Remote Code Execution Vulnerability in NashornScriptEngineCreator

Description

Remote Code Execution Vulnerability in NashornScriptEngineCreator is reported in Apache Ranger versions <= 2.7.0. Users are recommended to upgrade to version 2.8.0, which fixes this issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Ranger

Default version status: unaffected

  • 0 to ≤ 2.7.0affected

References