Skip to content
CVE PROGRAM SOURCE RECORD9.1 Critical

CVE-2025-58766

Dyad Vulnerable to Remote Code Execution via Top-level Navigation in Preview Window

Description

Dyad is a local AI app builder. A critical security vulnerability has been discovered that affected Dyad v0.19.0 and earlier versions that allows attackers to execute arbitrary code on users' systems. The vulnerability affects the application's preview window functionality and can bypass Docker container protections. An attacker can craft web content that automatically executes when the preview loads. The malicious content can break out of the application's security boundaries and gain control of the system. This has been fixed in Dyad v0.20.0 and later.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

dyad-sh dyad

  • < 0.20.0affected

References