Skip to content
CVE PROGRAM SOURCE RECORD9.7 Critical

CVE-2025-58357

5ire Chat Message XSS Vulnerability Enables Remote Code Execution

Description

5ire is a cross-platform desktop artificial intelligence assistant and model context protocol client. Version 0.13.2 contains a vulnerability in the chat page's script gadgets that enables content injection attacks through multiple vectors: malicious prompt injection pages, compromised MCP servers, and exploited tool integrations. This is fixed in version 0.14.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

nanbingxyz 5ire

  • >= 0.13.2, < 0.14.0affected

References