Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2025-58136

Apache Traffic Server: A simple legitimate POST request causes a crash

Description

A bug in POST request handling causes a crash under a certain condition. This issue affects Apache Traffic Server: from 10.0.0 through 10.1.1, from 9.0.0 through 9.2.12. Users are recommended to upgrade to version 10.1.2 or 9.2.13, which fix the issue. A workaround for older versions is to set proxy.config.http.request_buffer_enabled to 0 (the default value is 0).

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Traffic Server

Default version status: unaffected

  • 10.0.0 to ≤ 10.1.1affected
  • 9.0.0 to ≤ 9.2.12affected

References