Skip to content
CVE PROGRAM SOURCE RECORD5.5 Medium

CVE-2025-55296

LibreNMS allows stored XSS in Alert Template name field

Description

librenms is a community-based GPL-licensed network monitoring system. A stored Cross-Site Scripting (XSS) vulnerability exists in LibreNMS (<= 25.6.0) in the Alert Template creation feature. This allows a user with the admin role to inject malicious JavaScript, which will be executed when the template is rendered, potentially compromising other admin accounts. This vulnerability is fixed in 25.8.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

librenms librenms

  • < 25.8.0affected

References