Skip to content
CVE PROGRAM SOURCE RECORD5.1 Medium

CVE-2025-55209

FreePBX UCP is Vulnerable to Stored XSS Through its User Control Panel

Description

contactmanager is a module for FreePBX@, which is an open source GUI that controls and manages Asterisk© (PBX). In versions 15.0.14 and below, 16.0.0 through 16.0.26.4 and 17.0.0 through 17.0.5, a stored cross-site scripting (XSS) vulnerability in FreePBX allows a low-privileged User Control Panel (UCP) user to inject malicious JavaScript into the system. The malicious code executes in the context of an administrator when they interact with the affected component, leading to session hijacking and potential privilege escalation. This issue is fixed in versions 15.0.14, 16.0.27 and 17.0.6.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

FreePBX contactmanager

  • < 15.0.14affected
  • >= 16.0.0, < 16.0.27affected
  • >= 17.0.0, < 17.0.6affected

References