Skip to content
CVE PROGRAM SOURCE RECORD9.1 Critical

CVE-2025-55017

Apache IoTDB: Path Traversal Vulnerability

Description

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 2.0.0 before 2.0.6, from 1.0.0 before 1.3.6. Users are recommended to upgrade to version 1.3.6 and 2.0.6, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache IoTDB

Default version status: unaffected

  • 2.0.0 to < 2.0.6affected
  • 1.0.0 to < 1.3.6affected

References