Skip to content
CVE PROGRAM SOURCE RECORD6.0 Medium

CVE-2025-54869

FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser

Description

FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service (DoS) vulnerability. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. This issue is fixed in version 2.6.3.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Setasign FPDI

  • < 2.6.3affected

References