Skip to content
CVE PROGRAM SOURCE RECORD6.5 Medium

CVE-2025-5472

Denial of Service via Uncontrolled Recursive JSON Parsing in JSONReader in run-llama/llama_index

Description

The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Service (DoS) by submitting deeply nested JSON structures, leading to a RecursionError and crashing applications. The root cause is the unsafe recursive traversal design and lack of depth validation, which makes the JSONReader susceptible to stack overflow when processing deeply nested JSON. This impacts the availability of services, making them unreliable and disrupting workflows. The issue is resolved in version 0.12.38.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

run-llama run-llama/llama_index

  • unspecified to < 0.12.38affected

References