Skip to content
CVE PROGRAM SOURCE RECORD6.9 Medium

CVE-2025-54572

Ruby SAML DOS vulnerability with large SAML response

Description

The Ruby SAML library is for implementing the client side of a SAML authorization. In versions 1.18.0 and below, a denial-of-service vulnerability exists in ruby-saml even with the message_max_bytesize setting configured. The vulnerability occurs because the SAML response is validated for Base64 format prior to checking the message size, leading to potential resource exhaustion. This is fixed in version 1.18.1.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

SAML-Toolkits ruby-saml

  • < 1.18.1affected

References