Skip to content
CVE PROGRAM SOURCE RECORD6.9 Medium

CVE-2025-54571

ModSecurity's Insufficient Return Value Handling can Lead to XSS and Source Code Disclosure

Description

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. In versions 2.9.11 and below, an attacker can override the HTTP response’s Content-Type, which could lead to several issues depending on the HTTP scenario. For example, we have demonstrated the potential for XSS and arbitrary script source code disclosure in the latest version of mod_security2. This issue is fixed in version 2.9.12.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

owasp-modsecurity ModSecurity

  • < 2.9.12affected

References