Description
AIDE is an advanced intrusion detection environment. From versions 0.13 to 0.19.1, there is a null pointer dereference vulnerability in AIDE. An attacker can crash the program during report printing or database listing after setting extended file attributes with an empty attribute value or with a key containing a comma. A local user might exploit this to cause a local denial of service. This issue has been patched in version 0.19.2. A workaround involves removing xattrs group from rules matching files on affected file systems.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
aide aide
>= 0.13, < 0.19.2affected
References
- https://github.com/aide/aide/security/advisories/GHSA-79g7-f8rv-jcxh ↗
- https://github.com/aide/aide/commit/54a6d0d9d5f14b81961d66373c0291bf4af4135a ↗
- https://github.com/aide/aide/releases/tag/v0.19.2 ↗
- https://lists.debian.org/debian-lts-announce/2025/08/msg00011.html ↗
- http://www.openwall.com/lists/oss-security/2025/08/14/8 ↗