Skip to content
CVE PROGRAM SOURCE RECORD8.6 High

CVE-2025-5302

Denial of Service (DOS) in JSONReader in run-llama/llama_index

Description

A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

run-llama run-llama/llama_index

  • unspecified to < 0.12.38affected

References