Description
A vulnerability was found in erdogant pypickle up to 1.1.5 and classified as problematic. Affected by this issue is the function load of the file pypickle/pypickle.py. The manipulation leads to deserialization. Local access is required to approach this attack. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
erdogant pypickle
1.1.0affected1.1.1affected1.1.2affected1.1.3affected1.1.4affected1.1.5affected
References
- https://vuldb.com/?id.310262 ↗
- https://vuldb.com/?ctiid.310262 ↗
- https://vuldb.com/?submit.579157 ↗
- https://github.com/erdogant/pypickle/issues/2 ↗
- https://github.com/erdogant/pypickle/issues/2#issuecomment-2889146579 ↗
- https://github.com/erdogant/pypickle/commit/14b4cae704a0bb4eb6723e238f25382d847a1917 ↗
- https://github.com/erdogant/pypickle/releases/tag/2.0.0 ↗