Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2025-49763

Apache Traffic Server: Remote DoS via memory exhaustion in ESI Plugin

Description

ESI plugin does not have the limit for maximum inclusion depth, and that allows excessive memory consumption if malicious instructions are inserted. Users can use a new setting for the plugin (--max-inclusion-depth) to limit it. This issue affects Apache Traffic Server: from 10.0.0 through 10.0.5, from 9.0.0 through 9.2.10. Users are recommended to upgrade to version 9.2.11 or 10.0.6, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Traffic Server

Default version status: unaffected

  • 10.0.0 to ≤ 10.0.5affected
  • 9.0.0 to ≤ 9.2.10affected

References