Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2025-49506

Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack

Description

APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as  Windows, BeOS, NetWare, or Android. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Portable Runtime Utility

Default version status: unaffected

  • 1.2.0 to ≤ 1.6.3affected

References