Description
Uncontrolled Recursion vulnerability in Apache Commons Lang. This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0. The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop. Users are recommended to upgrade to version 3.18.0, which fixes the issue.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Apache Software Foundation Apache Commons Lang
Default version status: unknown
2.0 to ≤ 2.6affected
Apache Software Foundation Apache Commons Lang
Default version status: unaffected
3.0 to < 3.18.0affected
References
- https://lists.apache.org/thread/bgv0lpswokgol11tloxnjfzdl7yrc1g1 ↗
- https://lists.debian.org/debian-lts-announce/2025/09/msg00032.html ↗
- https://lists.debian.org/debian-lts-announce/2025/08/msg00026.html ↗
- https://lists.debian.org/debian-lts-announce/2025/08/msg00000.html ↗
- http://www.openwall.com/lists/oss-security/2025/07/11/1 ↗
- https://lists.debian.org/debian-lts-announce/2025/09/msg00036.html ↗