Skip to content
CVE PROGRAM SOURCE RECORD6.3 Medium

CVE-2025-48386

Git allows a buffer overflow in 'wincred' credential helper

Description

Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. The wincred credential helper uses a static buffer (target) as a unique key for storing and comparing against internal storage. This credential helper does not properly bounds check the available space remaining in the buffer before appending to it with wcsncat(), leading to potential buffer overflows. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

git git

  • < 2.43.7affected
  • >= 2.44.0-rc0, < 2.44.4affected
  • >= 2.45.0-rc0, < 2.45.4affected
  • >= 2.46.0-rc0, < 2.46.4affected
  • >= 2.47.0-rc0, < 2.47.3affected
  • >= 2.48.0-rc0, < 2.48.2affected
  • >= 2.49.0-rc0, < 2.49.1affected
  • >= 2.50.0-rc0, < 2.50.1affected

References