Skip to content
CVE PROGRAM SOURCE RECORD3.1 Low

CVE-2025-47279

undici Denial of Service attack via bad certificate data

Description

Undici is an HTTP/1.1 client for Node.js. Prior to versions 5.29.0, 6.21.2, and 7.5.0, applications that use undici to implement a webhook-like system are vulnerable. If the attacker set up a server with an invalid certificate, and they can force the application to call the webhook repeatedly, then they can cause a memory leak. This has been patched in versions 5.29.0, 6.21.2, and 7.5.0. As a workaound, avoid calling a webhook repeatedly if the webhook fails.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

nodejs undici

  • < 5.29.0affected
  • >= 6.0.0, < 6.21.2affected
  • >= 7.0.0, < 7.5.0affected

References