Description
Git GUI allows you to use the Git source control management tools via a GUI. When a user clones an untrusted repository and is tricked into editing a file located in a maliciously named directory in the repository, then Git GUI can create and overwrite files for which the user has write permission. This vulnerability is fixed in 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2, 2.49.1, and 2.50.1.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
j6t git-gui
< 2.43.7affected>= 2.44.0, < 2.44.4affected>= 2.45.0, < 2.45.4affected>= 2.46.0, < 2.46.4affected>= 2.47.0, < 2.47.3affected>= 2.48.0, < 2.48.2affected>= 2.49.0, < 2.49.1affected>= 2.50.0, < 2.50.1affected
References
- https://github.com/j6t/git-gui/security/advisories/GHSA-xfx7-68v4-v8fg ↗
- https://github.com/j6t/git-gui/compare/dcda716dbc9c90bcac4611bd1076747671ee0906..a437f5bc93330a70b42a230e52f3bd036ca1b1da ↗
- https://lists.debian.org/debian-lts-announce/2025/10/msg00003.html ↗
- http://www.openwall.com/lists/oss-security/2025/07/08/4 ↗