Skip to content
CVE PROGRAM SOURCE RECORD7.0 High

CVE-2025-46817

Lua library commands may lead to integer overflow and potential RCE

Description

Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

redis redis

  • < 8.2.2affected

References