Skip to content
CVE PROGRAM SOURCE RECORD7.3 High

CVE-2025-46731

Craft CMS Contains a Potential Remote Code Execution Vulnerability via Twig SSTI

Description

Craft is a content management system. Versions of Craft CMS on the 4.x branch prior to 4.14.13 and on the 5.x branch prior to 5.6.16 contains a potential remote code execution vulnerability via Twig SSTI. One must have administrator access and `ALLOW_ADMIN_CHANGES` must be enabled for this to work. Users should update to the patched versions 4.14.13 or 5.6.15 to mitigate the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

craftcms cms

  • >= 4.0.0-RC1, < 4.14.13affected
  • >= 5.0.0-RC1, < 5.6.15affected

References