Skip to content
CVE PROGRAM SOURCE RECORD9.8 Critical

CVE-2025-3466

Unsanitized Input in langgenius/dify

Description

langgenius/dify versions 1.1.0 to 1.1.2 are vulnerable to unsanitized input in the code node, allowing execution of arbitrary code with full root permissions. The vulnerability arises from the ability to override global functions in JavaScript, such as parseInt, before sandbox security restrictions are imposed. This can lead to unauthorized access to secret keys, internal network servers, and lateral movement within dify.ai. The issue is resolved in version 1.1.3.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

langgenius langgenius/dify

  • unspecified to < 1.1.3affected

References