Skip to content
CVE PROGRAM SOURCE RECORD8.7 High

CVE-2025-34115

OP5 Monitor <= 7.1.9 Authenticated Command Execution via command_test.php

Description

An authenticated command injection vulnerability exists in OP5 Monitor through version 7.1.9 via the 'cmd_str' parameter in the command_test.php endpoint. A user with access to the web interface can exploit the 'Test this command' feature to execute arbitrary shell commands as the unprivileged web application user. The vulnerability resides in the configuration section of the application and requires valid login credentials with access to the command testing functionality. This issue is fixed in version 7.2.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

ITRS Group OP5 Monitor

Default version status: unaffected

  • 0 to ≤ 7.1.9affected

References