Skip to content
CVE PROGRAM SOURCE RECORD2.7 Low

CVE-2025-32972

The lesscss script service allows cache clearing without programming right

Description

XWiki is a generic wiki platform. In versions starting from 6.1-milestone-1 to before 15.10.12, from 16.0.0-rc-1 to before 16.4.3, and from 16.5.0-rc-1 to before 16.8.0-rc-1, the script API of the LESS compiler in XWiki is incorrectly checking for rights when calling the cache cleaning API, making it possible to clean the cache without having programming right. The only impact of this is a slowdown in XWiki execution as the caches are re-filled. As this vulnerability requires script right to exploit, and script right already allows unlimited execution of scripts, the additional impact due to this vulnerability is low. This issue has been patched in versions 15.10.12, 16.4.3, and 16.8.0-rc-1.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

xwiki xwiki-platform

  • >= 6.1-milestone-1, < 15.10.12affected
  • >= 16.0.0-rc-1, < 16.4.3affected
  • >= 16.5.0-rc-1, < 16.8.0-rc-1affected

References